Minecraft Forge Users Unable to Connect
Incident Report for Friends Vanilla
Postmortem

The issue was twofold. The dedicated server did not support the IPv6 protocol, and proxied connections to the Minecraft server were being blocked, causing the "Failed to verify username" error. We made a request to our server provider around 2 in the morning to provide an IPv6 address space for us to use, and the following hours were spent configuring it, which required multiple dedicated restarts due to our netplan configuration refusing to apply live. We took this opportunity to update all of the packages on our server, which required us to keep the server offline for an extended period of time.

After configuring our networking to allow IPv6 address space and connections, including a modification to our CloudFlare DNS to add the AAAA records required to point the domain to an IPv6 address if requested upon connecting to the server, we noticed the "Failed to verify username" error did not go away. An extensive investigation was carried out partnered with Minecraft Forge contributor Paint_Ninja to investigate why this was the case. We investigated pinging various IPv6 address spaces and changing some JVM Arguments for the server, to no avail. We then turned our attention to the netplan configuration and ultimately determined it was set up correctly and working properly.

I began testing with a Vanilla, Minecraft Forge, Spigot, and PaperMC server, and was able to connect to all of them, but still not Friends Vanilla. I shifted my attention over to the plugins, and ran a PaperMC server with various combinations of our plugins, eventually putting all plugins in still without being able to reproduce the issue. As a last resort, I began copying over the Friends Vanilla PaperMC server configuration files until the issue was reproduced upon the copying of the server.properties file. This is when I discovered that Friends Vanilla was blocking proxy connections. The IPv6 connection was being considered a proxy, ultimately causing the "Failed to verify username" issue (which is used to deter attacks by making attackers think it's an issue on their end, not the server's). Following the changing of this option, it was found that all IPv6 connections were now working, marking the issue as resolved.

Posted Jun 05, 2023 - 20:28 MDT

Resolved
The issue has been resolved. IPv6 has officially been fixed. Minecraft Forge users are now able to connect to the server again without issue. I apologize this took so long, and I apologize for the interruptions to the service while we figured out the issue.
Posted Jun 05, 2023 - 01:43 MDT